What to do if replication freezes although the agent is still sending heartbeats to Acura

Replication freezes although the agent is still sending heartbeats to Acura

Challenge

Replication is stuck with a "Replicating" status in Acura Control Panel, although the agent's "Last seen" status is up-to-date and heartbeats are being sent.
Replication hangs       

Cause

A possible reason for such behavior might be that Acura and Hystax Cloud Agent don't have access to each other, so the replicated data can't be saved to the storage.

Solution

Make sure that Hystax Cloud Agent and Acura are in the same security group.
In case they are in different security groups, check whether the following ports are opened:
  • for Acura:
    • Ingress – tcp/443
    • Ingress – tcp/4443
    • Ingress – udp/12201

  • for Hystax Cloud Agent:
    • Ingress – tcp/80
    • Ingress – tcp/3260

  • for the replication agent:
    • tcp/443
    • tcp/udp/12201