Why a replicated/migrated machine doesn't show its network information in VMware ESXi
Challenge
Network information (IP, hostname) of a machine is not shown in VMware ESXi interface after a seemingly successful migration or replication.
Cause
No VMware Tools installed on the source machine.
Solution
In order for the source machine's network information to be displayed correctly in the target VMware ESXi interface, VMware Tools have to be installed manually prior to the replication/migration procedure.
Here is an example of how to install VMware Tools in a Windows guest operating system using the vSphere Client:
- Power on the virtual machine.
- Log in as a user with Administrator privileges.
- When the desktop is loaded, click VM in the virtual machine menu, then navigate to Guest > Install/Upgrade VMware Tools and click OK.
- If the installation doesn't start automatically, go to the CD Drive in the Windows Explorer and double-click setup.exe or setup64.exe.
- Follow the steps in the wizard to complete the installation.
- Restart the virtual machine for the changes to take effect.